以太坊伦敦升级已完成 矿工有哪些注意事项?

2021-09-15 08:30:09 来源 / 作者: / 耳朵财经 己有:-人学习过

客户端版本

​​为了兼容伦敦升级,节点运营商需要升级他们运行的客户端版本,下表是所有支持以太坊主网伦敦升级的客户端版本号。这些版本与之前公布的支持测试网伦敦升级的版本有所不同,多个之前的版本不支持以太坊主网伦敦升级。

支持以太坊主网伦敦升级的客户端版本号

注意:

1、Besu客户端版本于2021年8月4日更新,主要是修复与伦敦升级无关的、影响交易池的错误。

2、Go-ethereum、Nethermind和Erigon客户端版本均于2021年7月23日更新,主要解决Ropsten测试网共识问题。

3、伦敦升级后,OpenEthereum客户端将被弃用,OE 团队正在与Erigon合作,为用户提供平稳的过渡。

伦敦升级EIP

伦敦升级包括以下EIP:

  • ​EIP-1559:ETH 1.0链交易手续费市场变化
  • EIP-3198:BASEFEE操作码
  • EIP-3529:减少退款
  • EIP-3541:拒绝以0xEF字节开头的新合约
  • EIP-3554:难度炸弹延迟至2021年12月1日

​​需要注意的是,EIP-1559虽然向后兼容了当前的交易格式,但对区块头(Block header)进行了更改,添加了新的交易类型和新的JSON RPC端点,并更改了在多个场景下(挖矿、交易池等)的操作,强烈建议项目方都熟悉伦敦升级EIP的内容。

以太坊用户或ETH持币者需要做什么?

​​如果你使用的是交易所(例如Coinbase、Kraken或Binance)、网页钱包(例如 Metamask、MyCrypto 或 MyEtherWallet)、移动钱包(例如 Coinbase Wallet、Trust Wallet),或硬件钱包(例如 Ledger、Trezor),除非交易所或钱包服务通知你采取其他步骤,否则你什么都不需要做

非挖矿节点运营商需要做什么?

​​如果你运行了自己的以太坊节点,则需要升级你的节点。根据前文所列的客户端版本号,下载最新版本的以太坊客户端。

矿工需要做什么?

​​首先,根据前文所列的客户端版本号,下载最新版本的以太坊客户端。然后,你需要手动将Gas Limit设置为现在的两倍。例如,在伦敦升级之前,你设定的区块容量是15,000,000 gas,那么你现在需要将区块容量设为 30,000,000 gas。这是因为伦敦升级一旦激活,区块容量将增加一倍,而EIP-1559将使区块大小保持在区块容量的50%左右。这可以在所有兼容主网伦敦升级的客户端通过JSON-RPC端点完成,无需重新启动你的节点。

​​下表是每个客户端调整Gas Limit需要调用的API接口。

​​注意:Nethermind、Erigon和EthereumJS还不支持以太坊主网上的挖矿。

网络升级是如何发生的?

​​在社区就升级应包含哪些EIP达成共识后,对协议的更改就将写入各种以太坊客户端,例如 geth、Erigon、Besu和Nethermind,这些协议的更改将在特定的区块被激活。任何没有升级到新版本的节点都将被丢弃在旧链上,旧链上仍然使用旧的规则。

矿工或节点运营商不升级会怎样?

​​网络升级是对底层以太坊协议的更改,创建新规则来改进系统。区块链的去中心化特性使得网络升级更加困难。以太坊网络升级需要与以太坊社区以及各以太坊客户端的开发人员进行沟通合作,以确保升级顺利进行。

​​如果矿工或节点运营商的以太坊客户端没有升级到上面列出的最新版本,则伦敦升级后,你的客户端将继续同步硬分叉之前的链。你将被困在一条不兼容的链上,无法发送以太币或在伦敦升级之后的以太坊网络上进行操作。

免责声明:本文来自网络投稿,观点仅代表作者本人,不代表自链财经赞同其观点或证实其描述,版权归原作者所有,转载请注明出处。
温馨提示:投资有风险,入市须谨慎。本资讯不作为投资理财建议。